kernel, headers и драйвер wifi

  • никак не могу запустить wifi. m-a выдает что kernel configuration FAILED.
    если делаю просто make в директории madwifi, то драйвер компилится, и конфигурация кернеля правильная, но при dmesg выдает:
    ath_pci: disagrees about version of symbol struct_module
    wlan: disagrees about version of symbol struct_module
    те либо драйвер скомпилился не тот или версия кернеля не та. драйвер должен скомпилится тот тк в инструкции он поддерживает чип. а вот с кернелем не могу разобраться. дело в том что у меня стоял кернель 2.6.20.2, потом поставил кернель от bikalexa 2.6.23.1. в menu.lst стоит:
    /boot/vmlinuz-2.6.23.1 root=vmlinuz video=matroxfb root=/dev/hda1 acpi=force quiet
    те загружается 2.6.23.1, но vmlinuz показывает на 2.6.20.2
    сейчас поставил сырцы и хедеры 2.6.23.1.
    может надо было ставить 2.6.20.2? кто подскажет, в каком направлении копать.
    зы всех на наступающим

  • Цитата

    Со слов пользователя Bikalexander
    А что за карта то? И где ты для неё дарйверы скачивал?


    карта TP-Link, чип Atheros AR2413A. драйвера поддерживаются madwifi, скачивал с их сайта: Пожалуйста зарегистрируйся для просмотра данной ссылки на страницу. у меня вопрос только по компиляции, тк реально стоит твой кернель, uname -r показывает 2.6.23.1 а раньше стоял 2.6.20.2 и на него указывает vmlinuz в menu.lst. у меня пока один вопрос: мне компилить драйвера с сырцами 2.6.23.1 или 2.6.20.2?

  • uname -r показывает 2.6.18-5-686
    но на Пожалуйста зарегистрируйся для просмотра данной ссылки на страницу. нет таких сырцов. где их можно скачать? или 2.6.18.5 это то что надо?

  • apt-get update
    apt-get install linux-source-2.6.18-5-686
    Reading package lists... Done
    Building dependency tree... Done
    E: Couldn't find package linux-source-2.6.18-5-686


    нет такого. если нет других вариантов, придется, наверно, менят кернель и ставить под него уже сырцы

  • Хм. А не проще полностью пересобрать ядро ? Делов то на пару часов...
    Пожалуйста зарегистрируйся для просмотра данной ссылки на страницу.
    Пожалуйста зарегистрируйся для просмотра данной ссылки на страницу.
    ну и google конечно... =)